No android folder when using expo detach

#1

For some reason when using expo detach on my existing Expo project I don’t get a android folder but I get a ios folder. What might the reason for that be? My log looks like this:

14:31:28 [exp] Making sure project is set up correctly…
14:31:39 [exp] Your project looks good!
Validating project manifest…
Creating ExpoKit workspace at /Users/PATH/ios…
Downloading iOS code…
Moving iOS project files…
Attempting to create project directory…
project dir: /Users/PATH/ios
Created project directory! Copying files:
Naming iOS project…
Configuring iOS dependencies…
Configuring iOS project…
Modifying NSBundle configuration at /Users/PATH/ios/PATH/Supporting…
We added some permissions keys to Info.plist in your detached iOS project:
NSCalendarsUsageDescription
NSMotionUsageDescription
NSCameraUsageDescription
NSMicrophoneUsageDescription
NSRemindersUsageDescription
NSPhotoLibraryAddUsageDescription
NSContactsUsageDescription
NSPhotoLibraryUsageDescription
NSLocationWhenInUseUsageDescription
You may want to revise them to include language appropriate to your project. You can also remove them if your app will never use the corresponding API. See the Apple docs for these keys.
Using shell config: { manifestUrl: ‘exp://exp.host/@USERNAME/PROJECT_NAME’,
isShell: true,
releaseChannel: ‘default’,
isManifestVerificationBypassed: true }
Your iOS ExpoKit project will not contain an .entitlements file by default. If you need specific Apple entitlements, enable them manually via Xcode or the Apple Developer website.
Configuring iOS Launch Screen…
(node:10793) UnhandledPromiseRejectionWarning: Unhandled promise rejection (rejection id: 1): RequestError: Error: Invalid URI “./assets/icon.png”

#2

Hey @tovesson,

What version of exp are you running? If it’s not 51.4.0, can you update and try again? Also, double check with these docs and make sure your app.json is configured properly: https://docs.expo.io/versions/latest/distribution/building-standalone-apps#2-configure-appjson

Cheers,

Adam

#3

Hi Adam!
I did that already, checkin exp -V shows me I got version 51.4.0. I’ve also added bundleIdentifier and package in my app.json

#4

@tovesson Thanks for the clarification! I’ll bring this up to the team but with it being the weekend and a holiday today, it likely won’t be til tomorrow (at the earliest) that I can provide you with a possible solution.

Thanks,

Adam

#5

I figured it out! It’s because I had no icon.png in my assets folder. Should be a clearer warning saying the detach was terminated :slight_smile:

#6

Awesome! Glad you figured that out! I agree, we could certainly do a better job with the error handling. I’ll make a note internally. Thanks for your help!

Have a good day!

2 Likes
closed #7

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.