No sound with Audio API in iOS

#1

Hey guys!

Currently trying to play a simple audio file in my Expo app. Thing is: It plays wonderfully on Android but fails to play in iOS. Audio seems to load correctly, since no errors are shown, but sound is mute.

I tried with both mp3 and m4a files and no luck. Currently running iOS 10.3.2.

This issue also happens with expo’s playlist example. Any ideas? Is there a platform specific configuration I’m missing? Would love to hear if you guys are having the same issue.

Thanks guys!

#2

Hi @ramadis!

Have you made sure that your phone is not on silent? The default audio mode has playsOnSilentLockedModeIOS set to false. You can modify this by setting the audio mode using Expo.Audio.setAudioModeAsync().

Thanks! Let me know if this doesn’t work.

Greg

#3

Hey @greg,

I’m currently running the SDK v15.0.0. This version doesn’t seem to have the method you say. Anyway, iphone’s volume is full and as I said, not even the playlist example works. I assume it did when guys developed it, not sure what changed. I’ve seen an open issue in the playlist repo of another folk suffering the same predicament.

I’m reluctant to update to v17.0.0 since it would imply update to the store a new APK, and I already had issues with the play store blocking our app with no reason and never answering our complains.

Any other idea?

#4

Hi @ramadis,

That is very strange!

In SDK 15 the app only makes sound when the ring/silent switch is on “ring” mode, regardless of the volume of the phone.

Can you confirm that the app is not playing audio when on “ring” mode?

Thanks!

Greg

1 Like
#5

OH. MY. GOD. I knew I shouldn’t have passed the kindergarten. Yes, the switch was on Silent, I’m embarrassed. So, is it possible to play sound even in Silent mode on SDK v15, or the only option is to upgrade the sdk?

Thanks so much for your help @greg. I was going crazy.

#6

Hi @ramadis,

I am so glad that was your issue and now it works!!

Unfortunately, it is not possible to play sound in silent mode unless you upgrade your SDK version and set the playsInSilentLockedModeIOS audio mode flag to true.

Thanks! Let me know if you need anything else.

Greg

1 Like