Node.js version 14.0.0 is no longer supported

I am just getting started with Expo and trying to create my first project. I installed Node.js (v14.0.0) via Homebrew, and installed installed expo-cli using npm by running the following command as mentioned in the Expo quick start guide:

# Install the command line tools
npm install --global expo-cli

# Create a new project
expo init my-project

However, I received an error when running the expo init my-project command which looks like this:

ERROR: Node.js version 14.0.0 is no longer supported.

expo-cli supports following Node.js versions:

  • >=10.13.0 <11.0.0 (Active LTS)

  • >=12.0.0 <13.0.0 (Active LTS)

  • >=13.0.0 <14.0.0 (Current Release)

I tried running expo, expo-cli, expo diagnostics, and I keep getting the same error message every time. I am practically unable to run expo command.

I checked Node.js release notes, and turns out Node.js has recently been bumped to version 14.x.

Can someone familiar with Expo development and release timelines help with what should be the recommend approach here out of the following two?

  1. Downgrade to an older stable and Expo supported version of Node.js.

  2. Wait for an update to Expo (only if an update to Expo is in pipeline to be released soon).

I am using a Mac running the current latest public release of macOS Catalina version 10.15.4 (19E287).

1 Like

I upgraded brew and some other package (ffmpeg), and now I have this error. Impossible to work with Expo anymore.

1 Like

Solved it by doing :
brew uninstall node
brew install node@12
brew link --force --overwrite node@12

2 Likes

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.