Not able to create IPA file using command 'exp build:ios -c'


#1

Here is what I see in command prompt,
[exp] Making sure project is set up correctly…
[exp] Your project looks good!
[exp] Checking if current build exists…

[exp] No currently active or previous builds for this project.
[exp] Removed existing credentials
[exp]
Does not seem like WSL enabled on this machine. Download from the Windows app
store a distribution of Linux, then in an admin powershell, please run:

Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Windows-Subsystem-Linux

? How would you like to upload your credentials?
Expo handles all credentials, you can still provide overrides

We need your Apple ID/password to manage certificates and
provisioning profiles from your Apple Developer account.

Note: Expo does not keep your Apple ID or your Apple password.

? What’s your Apple ID? @appleid.com
? Password? **********
[exp] Validating Credentials…
Error: spawn C:\Windows\system32\bash.exe ENOENT
** at exports._errnoException (util.js:1020:11)

** at Process.ChildProcess._handle.onexit (internal/child_process.js:197:32)**
** at onErrorNT (internal/child_process.js:376:16)**
** at _combinedTickCallback (internal/process/next_tick.js:80:11)**
** at process._tickCallback (internal/process/next_tick.js:104:9)**

I am using Windows 10 machine and in past, I have created several IPAs. After upgrading it to latest exp (49.0.3), I am not able to create the IPA and I am stuck here, Could you please help me out here?


WSL not enabled on this machine when running "exp build:ios"
#2

Hi, can you do:

gcm bash.exe

What versions of exp did you make IPAs before with?


#3

It must be <=47.0.0.


#4

Okay well that was driven by a different kind of authentication scheme.

Please follow the warning & instructions printed to you by exp:

Does not seem like WSL enabled on this machine. Download from the Windows app
store a distribution of Linux, then in an admin powershell, please run:

Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Windows-Subsystem-Linux

#5

Perfect! I will try this.


#6

It worked! Thanks a lot!


closed #7

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.