Not receiving push notifications on iOS when app is in foreground

#1

The listener given to Notifications.addListener is never fired while the iOS app is in foreground. It works fine on Android.

1 Like
#2

Can u Give more info about your app?

Like SDK Version, Standalone or Detached? app.json config.

Update: (U can join this post)

#3

i have the same problem
{
“expo”: {
“name”: “game”,
“description”: “This project is really great.”,
“slug”: “game”,
“privacy”: “public”,
“sdkVersion”: “27.0.0”,
“platforms”: [“ios”, “android”],
“version”: “1.0.0”,
“orientation”: “portrait”,
“icon”: “./assets/icon.png”,
“splash”: {
“image”: “./assets/splash.png”,
“resizeMode”: “contain”,
“backgroundColor”: “#ffffff
},
“notification”: {
“icon”: “./resources/icons/Coffee.png”
},
“updates”: {
“fallbackToCacheTimeout”: 0
},
“assetBundlePatterns”: [
“**/*”
],
“ios”: {
“supportsTablet”: true
}
}
}

#4

@notbrent say it’s a bug

#5

Hi ! glad to hear i am not alone in this case. I’m facing this issue since a couple of hours and i was desperated.

However works perfectly on android.

#6

Hi all – this was a server issue on our end which has been fixed. Notifications should be routed properly in the Expo client now. Let us know if you continue to see this issue.

1 Like
#7

Hi, @esamelson I have the same issue which is not fixed now. After the change You have made the notification view also does not work. If You need more information please contact with me I can reproduce the problem.

closed #8

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.