(NOT UPDATING THE APP) EXPO HAS BAG (expo: 24.0.0)


#1

I published app on google play first time ( versionCode: 1 ), after some UPGRATE I decide to launch new version and I change ( inside app.json) versionCode: 2, and version: 1.1.0 However after that I run command again ( exp build:android ) and Download apk file from server, but it was NOT UPDATED, versionCode left same and all changes, as result I can not download new version to google play ( Upload failed
An APK file with version 1 code already exists. Use another code. )

I hope Expo team will solve this problem as fast as it is possible( or I have made something wrong )


#2

What version of exp are you using? I ran into this the other day and then my problem was that I had update exp and now the build command acts differently than before (it does not build your app by default and publish it).

See here: https://github.com/expo/expo/issues/1303

And now I see that they have even reverted this change back in version 49 of exp (see last comment in link)


closed #3

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.