Packager strating but not giving an address


#1

I’m having issues with my packger, blocking in loading.
It starts well :

11:58:54 Starting React Native packager...
11:58:56 Scanning 774 folders for symlinks in C:\Users\b.mathieu\DevProject\node_modules (32ms)
11:58:57 
11:59:11 Dependency graph loaded.

It then keeps loading forever.
I also have 2 new issues that appeared :

Warning: Not using the Expo fork of react-native. See https://docs.expo.io/.

Warning: Expo version in package.json does not match sdkVersion in manifest.
If there is an issue running your project, please run `npm install` in C:\Users\b.mathieu\DevProject and restart.

But I can’t seem to be able to resolve them. I changed my SdKVersion in app.json, I ran npm install with and without node_modules, and nothing changes.


#2

Can you show me which SDK version you’re using? Let me show you an example of my package.json

  "dependencies": {
    "expo": "20.0.0",
    "react": "16.0.0-alpha.12",
    "react-native": "https://github.com/expo/react-native/archive/sdk-20.0.0.tar.gz",
  },

Maybe that will help you out? Just rm -rf node_modules and try with those?


#3

I’m also getting stuck at the Dependency graph loaded. part.

My dependencies are the same ones listed by @jimmylee and reinstalling them with npm or yarn does not solve the problem.

I’m on a Mac, watchman is installed as well.


#4

I ended up recreating a new app, and copying my old app.js in it. It works, so i think i must have fucked up some Update or something :slight_smile:


#5

That’s a pity! I am having the same issues, followed the blog post about upgrading to 20.0.0 but facing this issue. Also for some reason, expo is not able to read the package.json and app.json properly. It says the following although my sdkVersion and react-native version is pointing to 20.0.0

[exp] Warning: You are using npm version 5.3.0. There may be bugs in this version, use it at your own risk. We recommend version 4.6.1.
[exp] Warning: Problem validating asset fields in app.json. See https://docs.expo.io/
[exp]  • 'icon' should have dimensions 512x512, but the file at './app/assets/images/logo-scanapp.png' has dimensions 287x226.
[exp]  • 'icon' should be square, but the file at './app/assets/images/logo-scanapp.png' has dimensions 287x226.
[exp] Warning: Invalid version of react-native for sdkVersion 19.0.0. Use github:expo/react-native#sdk-19.0.0
[exp] Your JavaScript transform cache is empty, rebuilding (this may take a minute).
[exp] Warning: Expo version in package.json does not match sdkVersion in manifest.

#6

@madhums madhums this may be a stupid question, can you check your app.json and make sure "sdkVersion": "20.0.0" and

    "expo": "20.0.0",
    "react": "16.0.0-alpha.12",
    "react-native": "https://github.com/expo/react-native/archive/sdk-20.0.0.tar.gz",

are your dependencies in package.json?