React 16.5.0 -> React 16.6.3


#1

Hi.
Expo (sdk31) come with React 16.5.0, ¿it’s possible to update to React 16.6.3 in sdk31 or is better wait to sdk32?
Thanks.


#2

Hey Leandro,

It’s usually much easier to wait for an SDK release as it is a relatively complex process, but if you really need (or want) to upgrade versions I’ll see if I can get you pointed in the right direction of forking and getting the fork to play well with the Expo wrapper.

Cheers,

Adam


#3

I’m interested in the way that React context uses MyComponent.contextType = AppContext; I could solve it in another way, I think I can survive waiting for a new SDK. Like to learn, do you have any link from which you can read and learn to do the update process? Thank you very much for your answer. Greetings.

Leandro


#4

Any information when SDK which allows using react 16.6.x will be released?
I’m also very interested in using context API.

Cheers,
Pawel