react-native-screens v3.1.1

I recently updated Expo to SDK41 and ran into a major issue with react-native-screens v3.0.0 that is included. It contains bugs that have now been fixed in v3.1.1.

What are my options if I want to continue using Expo with the screens v3.1.1? Do I have to eject until the next Expo release?

we’re going to look into updating this soon. if you update to the latest version and do your build with eas build it’ll be included in your standalone app, so that’s a workaround for now.

Excellent! Now I have to figure out how to build that version but that’s on me. Thanks again, Brent!

you might find these WIP docs helpful: [docs] Managed EAS Build by brentvatne · Pull Request #12626 · expo/expo · GitHub

1 Like

I really like the idea of EAS but I’m not there yet. I’ll wait until you release an updated version of Expo. Are we talking about days or maybe weeks? Thanks!

we released a patch to the ios client in the simulator and expo build so that this is fixed. we included this fix. install the latest client with expo client:install:ios. we’ll release a new version of expo go to the app store soon.

That’s great news! Thank you for fixing that issue that fast!

1 Like