React native version mismatch :( in sdk 34.0.0

I tried to migrate a project made with sdk 32.0.0 but this does not suppor the bit 64 requirement for publishing in Android, so what I decided to do is to create another project with the latest version of react native and sdk 34.0.0 so now when I run expo start I got that red screen.

"dependencies": {
    "@ant-design/react-native": "^3.1.13",
    "expo": "^34.0.1",
    "lottie-react-native": "^3.1.0",
    "react": "16.8.3",
    "react-dom": "^16.8.6",
    "react-native": "https://github.com/expo/react-native/archive/sdk-34.0.0.tar.gz",
    "react-native-fetch-polyfill": "^1.1.3",
    "react-native-gesture-handler": "^1.3.0",
    "react-native-indicators": "^0.13.0",
    "react-native-masked-text": "^1.13.0",
    "react-native-modal-datetime-picker": "^7.5.0",
    "react-native-modalbox": "^1.7.1",
    "react-native-paper": "^2.16.0",
    "react-native-push-notification-popup": "^1.3.0",
    "react-native-qrcode": "^0.2.7",
    "react-native-qrcode-svg": "^5.1.2",
    "react-native-raw-bottom-sheet": "^2.0.2",
    "react-native-svg": "^9.6.2",
    "react-native-text-input-mask": "^1.0.6",
    "react-native-timeline-listview": "^0.2.3",
    "react-native-web": "^0.11.4",
    "react-navigation": "^3.11.1",
    "react-navigation-material-bottom-tabs": "^1.0.0",
    "react-redux": "^7.1.0",
    "redux": "^4.0.4",
    "redux-logger": "^3.0.6",
    "redux-thunk": "^2.3.0",
    "socket.io-client": "^2.2.0"
  },

You need to update your app.json “sdkVersion”

1 Like

Check here: Expo SDK 34 is now available :smiley:

After updating all the dependencies in package.json (and app.json as @ashishrooar suggested), you can run expo start -c to clear the cache. That should work, but lmk if you are still seeing issues afterwards

I did that, now I’m having another problem.
I import Constants like that. import { Constants, LinearGradient } from 'expo';
and this is happening.

Yeah, you need to update your imports and expo install your Expo packages

for constants, run expo install expo-constants and import like this:

import Constants from 'expo-constants';

it says “install” is not an expo command, I had expo-cli 2.6.14 now I’m trying tu upgrade with npm install -g expo-cli, it should work it right I suppose?

Yes, expo install should work with a later version of expo-cli

1 Like

I got the latest version of expo-cli and tried tu run expo install expo-constants
but ““install” is not an expo command. See “expo --help” for the full list of commands.” stills ocurrs

can you run expo diagnostics

Now it is working but the problem is that I used to use import { Constants, LinearGradient } from 'expo';
so now I have to import every Component from expo separetly?

yep, this is described in release notes for sdk 33 and 34:

1 Like

great thank you guys, I didnt know that I’m submitting my app to play store.