React Native version mismatch

#1

So recently i have updated to new version of expo
package.json

   "expo": "^28.0.0",
     .........
   "react": "16.3.1",
   "react-native": "https://github.com/expo/react-native/archive/sdk-28.0.0.tar.gz",

app.json

 "sdkVersion" : "28.0.0",

Everything worked perfect for a week or so… and then i started getting this error when i run expo start or even with expo start -c

Error :

console.error: "React native version mismatch.
JavaScript version: 0.55.4
Native version 0.52.0

and on npm -ls i get

npm ERR! peer dep missing: react-native@^0.51 || ^0.52 || ^0.53 || ^0.54, required by react-native-maps@0.21.0
.....
and many more that most probably are related to this.

also when i use yarn start then open it in android emulator the same happens.
Anyone else faced this issue and found the solution to this ?

#2

Hey @mits,

I’m running a project on SDK28 without any issue. If you haven’t already, I would try deleting your node_modules and installing them again. Also, just in case, what version of the expo-cli are you running?

Cheers,

Adam

#3

Hey @adamjnav , I `ve already tried removing the node_modules.

exp --version
57.0.0

Whats weird its that i haven’t touch my code for a week where everything was running perfect . And as soon i check it yesterday my LGV30 displays the error that i mentioned above.
if i run exp android my android displays the “Cannot load expo …”
And on a Samsung s8 everything works perfect.

closed #4

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.