`resolve/lib/core` is deprecated; please use `is-core-module` directly

I’m geeting this error when runing expo start

The app is still running locally, so maybe it’s just a warning

resolve/lib/core is deprecated; please use is-core-module directly`

Sounds like a warning, but can you please run expo diagnostics and post the output here?

  Expo CLI 3.28.0 environment info:
    System:
      OS: macOS 10.15.7
      Shell: 5.7.1 - /bin/zsh
    Binaries:
      Node: 12.16.1 - ~/.nvm/versions/node/v12.16.1/bin/node
      Yarn: 1.21.1 - /usr/local/bin/yarn
      npm: 6.13.4 - ~/.nvm/versions/node/v12.16.1/bin/npm
      Watchman: 4.9.0 - /usr/local/bin/watchman
    Managers:
      CocoaPods: 1.5.3 - /usr/local/bin/pod
    SDKs:
      iOS SDK:
        Platforms: iOS 13.1, DriverKit 19.0, macOS 10.15, tvOS 13.0, watchOS 6.0
    IDEs:
      Android Studio: 3.1 AI-173.4819257
      Xcode: 11.1/11A1027 - /usr/bin/xcodebuild
    npmPackages:
      expo: ~39.0.2 => 39.0.3
      react: 16.13.1 => 16.13.1
      react-dom: 16.13.1 => 16.13.1
      react-native: ~0.63.3 => 0.63.3
      react-native-web: ~0.13.12 => 0.13.18
    npmGlobalPackages:
      expo-cli: 3.28.0
    Expo Workflow: bare

OK, nothing obviously wrong there.

Can you post the whole error? Unfortunately, googling the error message does not turn up anything useful.

This is from expo publish

Building optimized bundles and generating sourcemaps...
Starting Metro Bundler.
Building iOS bundle
`resolve/lib/core` is deprecated; please use `is-core-module` directly

transform[stderr]: `resolve/lib/core` is deprecated; please use `is-core-module` directly
transform[stderr]: `resolve/lib/core` is deprecated; please use `is-core-module` directly
transform[stderr]: `resolve/lib/core` is deprecated; please use `is-core-module` directly
transform[stderr]: `resolve/lib/core` is deprecated; please use `is-core-module` directly
transform[stderr]: `resolve/lib/core` is deprecated; please use `is-core-module` directly
transform[stderr]: `resolve/lib/core` is deprecated; please use `is-core-module` directly

I’m having trouble figuring out what Google search results are relevant.

What dev dependencies + versions do you have?

Have you customised your babel or metro configs?

Any chance you can remove your node_modules and reinstall the deps?