RN UI kits that work with Expo?

#1

Hi,
I just started a mobile app project using Expo, but in the meantime trying to use existing UI libraries such as NativeBase, RN Elements or Shoutem (WIX react-native-ui-lib as well). However, none of these works in the sense just including them in the render() function. Typical errors are unrecognized element names etc.

Does anyone know if this is doable and what’s the trick to get it working, if indeed possible? Thanks a lot.

1 Like

#2

Hey @joseph7h,

You can use these UI libraries with Expo. You just need to make sure you’ve installed them via yarn or npm and that you are properly importing whatever components you are using.

Cheers,

Adam

0 Likes

#3

It’s surely more complicated than that. I did a npm install for every one of them, but none ended up working. I thought maybe an expo detach is needed to fix this.

0 Likes

#4

Nope, unless things have changed.


0 Likes

#5

you probably don’t want to use shoutem/ui because the company is now defunct. i’d personally recommend https://github.com/callstack/react-native-paper

2 Likes

#6

Here is some version info:

expo: 2.2.0
react-native: 0.57.3
native-base: 2.8.1
react-native-elements: 0.19.1

Strangely, in my package.json, I have an entry “react-native”: “https://github.com/expo/react-native/archive/sdk-30.0.0.tar.gz”. VS Code says invalid version entered. No sure how big a deal is that.

Let me check out rn-paper mentioned by @notbrent. Hope I got some luck now.

Many thanks to you both @adamjnav, @notbrent for trying to help.

0 Likes

closed #7

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

0 Likes