run builded app in ios 11.4 simulator crash immediately

#1

hi,
my app is running well when I publish on expo by exp publish.

however when I did ‘‘exp build:ios -t simulator’’ and got .tar and unzipped it installed on the simulator, the app got crashed very immediately after the splash.png shows

my expo version is 24.0.0

and I am a little confused about the .tar file I downloaded. cuz in the documentation it said I shall get a .tar.gz file

please help. thank you

#2

Hi, it’s possible you have some code that is behaving differently in production. You might try testing your app in Expo Client with dev=false and minify=true to see if you can reproduce the issue.

#3

do you mean i should run cli command of:
exp start --minify --no-dev
right? and following logs:
lanType":“ip”,“dev”:false,“minify”:true,“urlRandomness”:“fu-fk4”,“hostType”:“lan”

well, my app is running smoothly in this mode too, no issue.
then what shall i do, my friend. thank you

#4

i think my running was always Expo Client with dev=false and minify=true before.

i changed to Expo Client with dev=true and minify=true this time when i start the app it goes to a red console error screen:

"You are currently using minified code outside of NODE_ENV === 'production'. This means that you are running a slower development build of Redux. You can use loose-envify (https://github.com/zertosh/loose-envify) for browserify or DefinePlugin for webpack (http://stackoverflow.com/questions/30030031) to ensure you have the correct code for your production build."

may that be the reason of my standalone app crashes on both simulator and testflight download on a ios device?

#5

even i had changed the setting of the settings.json file:
{
“hostType”: “tunnel”,
“lanType”: “ip”,
“dev”: false,
“minify”: true,
“urlRandomness”: null
}
still crashing after i got it build with build:ios -t simulator

i checked the crash log:

it shows:

*** Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: ‘data parameter is nil’

#6

its my tabnavigator and stacknavigator problem~

now everything is working fine!

got it solved and thank you!

1 Like
My standalone app crashes on launch
closed #7

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.