SDK Version 36 is invalid

Please provide the following:

  1. SDK Version: 36
  2. Platforms(Android/iOS/web/all): All

I have been working with expo and react native for an app, I am able to test on my iphone and android devices. I kept getting the following error:

Error: Invalid sdkVersion. Valid options are 10.0.0, 11.0.0, 12.0.0, 13.0.0, 14.0.0, 15.0.0, 16.0.0, 17.0.0, 18.0.0, 19.0.0, 20.0.0, 21.0.0, 22.0.0, 23.0.0, 24.0.0, 25.0.0, 26.0.0, 27.0.0, 28.0.0, 29.0.0, 30.0.0, 31.0.0, 32.0.0, 33.0.0, 7.0.0, 8.0.0, 9.0.0

I am attempting to use version 36.0.0 And it works marvelously on the devices. Now I am ready to build the app in order for me to submit it to the apple and play stores. The issue I am having is that when I do

expo build:ios

it returns the following error:

Error: Invalid sdkVersion. Valid options are 10.0.0, 11.0.0, 12.0.0, 13.0.0, 14.0.0, 15.0.0, 16.0.0, 17.0.0, 18.0.0, 19.0.0, 20.0.0, 21.0.0, 22.0.0, 23.0.0, 24.0.0, 25.0.0, 26.0.0, 27.0.0, 28.0.0, 29.0.0, 30.0.0, 31.0.0, 32.0.0, 33.0.0, 7.0.0, 8.0.0, 9.0.0

Request failed with status code 400

I have tried doing an expo update but I get the following message:

You are currently using SDK 36.0.0. Would you like to update to the latest ver
sion, 32.0.0?

My react native version is: 3.2.1

My Expo Version is: 3.13.2

Anyone knows how can I fix this issue?

You should update the Expo CLI version: npm install -g expo-cli

Tried it but I get the same error. Do you know what is the latest expo-cli version there is?
After the Update command I am now on: 3.13.5

It’s very strange, please restart your console and run:

  1. npm i -g expo-cli
  2. expo --version (the latest version is 3.13.5)
  3. expo upgrade
  4. expo build:ios

You can also remove Expo CLI and try again:

npm -g uninstall expo-cli --save

Same error over here, I tried the steps you sent:

when i do expo upgrade I get:

You are currently using SDK 36.0.0. Would you like to update
 to the latest version, 32.0.0?

and keep getting the same issue on the top

I got the same error yesterday but from Expo client, which wasn’t up to date. Do you happen to have an old version of the Expo client installed on your machine/simulator?

Also, can you post your package.json?

Yeah I just deleted and re installed the expo client app on my devices. The error occurs even before I select to use the device. When I run it on the devie it runs perfectly. the issue is when I try to do a build:ios or build:android

Here is the package.json

{
  "main": "node_modules/expo/AppEntry.js",
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "web": "expo start --web",
    "eject": "expo eject",
    "test": "jest --watchAll"
  },
  "jest": {
    "preset": "jest-expo"
  },
  "dependencies": {
    "@expo/samples": "~36.0.0",
    "@expo/vector-icons": "^10.0.0",
    "@react-native-community/masked-view": "0.1.5",
    "@react-navigation/native": "^5.0.4",
    "@react-navigation/stack": "^5.0.4",
    "@react-navigation/web": "~1.0.0-alpha.9",
    "expo": "^36.0.0",
    "expo-asset": "~8.0.0",
    "expo-constants": "~8.0.0",
    "expo-font": "~8.0.0",
    "expo-secure-store": "~8.0.0",
    "expo-web-browser": "~8.0.0",
    "lodash": "^4.17.15",
    "mobx": "^5.15.4",
    "mobx-react": "^6.1.8",
    "react": "16.8.3",
    "react-dom": "~16.9.0",
    "react-native": "https://github.com/expo/react-native/archive/sdk-36.0.0.tar.gz",
    "react-native-base64": "0.0.2",
    "react-native-chart-kit": "^5.1.1",
    "react-native-elements": "^1.2.7",
    "react-native-gesture-handler": "~1.5.0",
    "react-native-paper": "^3.5.1",
    "react-native-reanimated": "~1.4.0",
    "react-native-safe-area-context": "0.6.0",
    "react-native-safe-area-view": "^1.0.0",
    "react-native-screens": "2.0.0-alpha.12",
    "react-native-svg": "9.13.3",
    "react-native-vector-icons": "latest",
    "react-native-web": "~0.11.7",
    "react-navigation": "~4.0.10",
    "react-navigation-stack": "~1.10.3",
    "react-navigation-tabs": "~2.6.2",
    "victory-native": "^34.0.0"
  },
  "devDependencies": {
    "@babel/core": "^7.0.0",
    "babel-preset-expo": "~8.0.0",
    "jest-expo": "^36.0.0"
  },
  "private": true
}

Yeah I just deleted and re installed the expo client app on my devices. The error occurs even before I select to use the device. When I run it on the devie it runs perfectly. the issue is when I try to do a build:ios or build:android

Here is the package.json

{
  "main": "node_modules/expo/AppEntry.js",
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "web": "expo start --web",
    "eject": "expo eject",
    "test": "jest --watchAll"
  },
  "jest": {
    "preset": "jest-expo"
  },
  "dependencies": {
    "@expo/samples": "~36.0.0",
    "@expo/vector-icons": "^10.0.0",
    "@react-native-community/masked-view": "0.1.5",
    "@react-navigation/native": "^5.0.4",
    "@react-navigation/stack": "^5.0.4",
    "@react-navigation/web": "~1.0.0-alpha.9",
    "expo": "^36.0.0",
    "expo-asset": "~8.0.0",
    "expo-constants": "~8.0.0",
    "expo-font": "~8.0.0",
    "expo-secure-store": "~8.0.0",
    "expo-web-browser": "~8.0.0",
    "lodash": "^4.17.15",
    "mobx": "^5.15.4",
    "mobx-react": "^6.1.8",
    "react": "16.8.3",
    "react-dom": "~16.9.0",
    "react-native": "https://github.com/expo/react-native/archive/sdk-36.0.0.tar.gz",
    "react-native-base64": "0.0.2",
    "react-native-chart-kit": "^5.1.1",
    "react-native-elements": "^1.2.7",
    "react-native-gesture-handler": "~1.5.0",
    "react-native-paper": "^3.5.1",
    "react-native-reanimated": "~1.4.0",
    "react-native-safe-area-context": "0.6.0",
    "react-native-safe-area-view": "^1.0.0",
    "react-native-screens": "2.0.0-alpha.12",
    "react-native-svg": "9.13.3",
    "react-native-vector-icons": "latest",
    "react-native-web": "~0.11.7",
    "react-navigation": "~4.0.10",
    "react-navigation-stack": "~1.10.3",
    "react-navigation-tabs": "~2.6.2",
    "victory-native": "^34.0.0"
  },
  "devDependencies": {
    "@babel/core": "^7.0.0",
    "babel-preset-expo": "~8.0.0",
    "jest-expo": "^36.0.0"
  },
  "private": true
}

Just fixed it!

to fix the issue:

  1. npm uninstall -g expo-cli --save

  2. npm install -g expo-cli --save

  3. cd ~/.expo/cache

  4. rm -rf everything that is in there

  5. go back to your project

  6. run expo start

2 Likes

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.