Section List Lag on iPhone X iOS 11.4

#1

So far we’re loving the expo community and react-native.

One of the pages in our app consists of a section list with different cells. The cells contains a combination of views, images, text for the most part.

On iPhone 6 iOS 11.3, scrolling is smooth. On iPhone X 11.4, the scrolling is just a bit coppy.

I checked to make sure nothing was causing multiple renders. The view works smooth on the iPhone 6 so I don’t think its Image size.

Any ideas?

Notice: This is 2 Modals deep using React-Navigation

Edit: Also, animation/transitioning into this view seems a bit laggy/slow as well.
Edit: It’s only happened twice but sometimes when transitioning into this screen the app restarts.
Edit: Slow/Choppiness exists in the simulator as well

0 Likes

Lag on iPhone 8 & higher
#2

Hi! Super glad to have you :).

Very interesting that you’re seeing worse performance on newer devices. Is there any chance you’d be able to provide a stripped down repro for this? Snack is usually pretty good for that.

0 Likes

#3

Ive never used Snack before so let me give it a try

0 Likes

#4

https://snack.expo.io/H14g80fXm

I think this is it.

Notice: Calendar, DatePicker and ListPicker are commented out (Along with image) because I just didnt know how to get it working on Snack

@dikaiosune See edit as well. Could be helpful

0 Likes

#5

Awesome, thanks! I’m tracking down a test device to try to repro this. If you get a chance and can take a video of exactly what you’re seeing on device, that would be awesome!

Also, just to confirm, you’re using production (dev=false) mode for your JS bundle on both phones, right?

0 Likes

#6

How do you set that? I’ve noticed this lag on a device which ran from a standalone app sent through apples testflight. Do I need to specify dev=false before expo build:ios?

But yes both phones are running the same app from testflight

0 Likes

#7

Nope, a standalone build should have the right configuration specified during that process. Thanks!

0 Likes

#8

No problem. I was having laggy issues with orientation switching as well (i posted another question on expo forum) could this be related? The orientation lag was on both devices, and on all pages. Sounds unrelated but there both lags on renders (View transition, Scrolling, Orientation change) just a thought, more info the better.
Also I really appriciate the help

0 Likes

#9

@dikaiosune Any udpate?

0 Likes

#10

@dikaiosune Do you have any update son this?

0 Likes

closed #11

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

0 Likes