Set Network Interface in settings.json

#1

Hello,

I try to use the Expo App on my Iphone to develop a react-native app.

But if I start the App with npm start it uses the first network interface on my Win10 PC. But this is a virtual network device and so the wrong ip which is encode into the QRCode. In the App on my Iphone I can only connect to a server over the QR Code.
My Question is: Can I configure the network Interface I want to use? In .expo/settings.json or anywhere else?

regards
Chris

#2

hi there! are you using create-react-native-app, XDE, or exp?

#3

Hi,
yes I used create-react-native-app.

I used this tutorial https://facebook.github.io/react-native/docs/getting-started.html

And after you start the app with npm start you can see the problem if your first network interface is not the one with which you are connected to your LAN/WLAN.

#4

Is there any fix for this yet, other than setting the IP manually: Window wrong IP Address when working on remote device?