Sharing cookies created on expo-AuthSession

Hi
My issue is that im using {AuthSession} from expo.
The issue happens only with Safari in-browser on my iphone. On Chrome on android all works well.
The authentication happens on the safari my subDomain (auth.romach-dev.com).

After authenticating, I am opening a safari in-browser from my expo app, and getting to the same auth page, but the cookie from the previous login is not shared.

But, If I am flipping the order and starts with authenticating to the wp.romach-dev.com (my wordpress app) from my safari and then going to the expo app and use the expo-authSession to authenticate, the cookies are shared and Im automatically logged in.

I wonder if there is some configuration I should set for AuthSession to meet requirements for using cookies with safari (https://webkit.org/blog/9521/intelligent-tracking-prevention-2-3/)

The documentation on AuthSession mentions this explicitely:

Note: the web browser should share cookies with your system web browser so that users do not need to sign in again if they are already authenticated on the system browser – Expo’s WebBrowser API takes care of this.

Are you per chance not using Expo’s WebBrowser to redirect the user to sign-in?

Hi,
It worked well.
I used AuthSession.startAsync(options) to auth from the mobile-app and WebBrowser.openAuthSessionAsync(url, redirectUrl) to open the other authed web pages.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.