Snack not updating on device

My snack doesn’t seem to update.

Example: https://snack.expo.io/@smitel/github.com-expo-sqlite-example

When I change something in screens/HomeScreen.js my device does say “Updating” but it doesn’t show the changes.

Any clue?

Hey @smitel,

There is an undefined object error when I open that. Nonetheless, changing the background color resulted in a reload. Can you make sure the device is listed on the connected devices menu in the bottom right? Also, it’d be good to try testing with a new Snack to see if the same behavior occurs.

Cheers,
Adam

Fixed.

The problem isn’t that it doesn’t result in a reload. The problem is that the reload doesn’t show the changes. For instance when I change the title.

It is.

The problem does not appear with a new snack. I feel like it’s got something to do with the navigation preventing the change from ‘going through’, but I don’t understand RN/Expo/etc. enough yet.

I made a new snack: https://snack.expo.io/@smitel/podcast-thingy-test-2

Once I seperate my style into a seperate import, changes in it don’t update on my device until I kill the expo app and reload my snack. When I inline the stylesheet the changes do update on my device.

I’ve tried to simplify my problem as much as possible:

When I seperate the styles in the App.js, changes to styles.js do appear on the right: https://snack.expo.io/@smitel/3c8619

When I seperate the styles in a seperate component, changes to styles.js do not appear on the right: https://snack.expo.io/@smitel/819887

The only difference between the two is putting the contents in a seperate component.
I test by changing the background color. It does show it’s updating on the right, but the changes do not take effect.

Does this make sense? Can you help me?

Thanks for the very detailed report @smitel. I relayed this internally and we’ll follow up when we know more.

1 Like

Hi @smitel Thanks for the great report :slight_smile:
Changes to any of the files in the project should now be reflected without needing a full reload

1 Like

Thank you both for your quick reponse and kind words. I’ve checked and the problem is fixed in my examples.

To be clear, the problem was not with my code but somewhere in Expo?

Yes, a caching bug in the snack client app to be specific.

2 Likes