[solved] Failing iPad Review for iPhone-only app. How can I test in 2x mode in Expo?

#1

Hey,

Could be coincidence but our iPhone app has been failing the iPad review which has never happened in the past.

They’re sending screenshots for the 2x / 1x mode which I can’t seem to access in any way. Is the only option really a real iPad for testing?

Are there any options for testing this in the Simulator?
Could it be that supportsTablet: false isn’t working the way it should?

Any help would be appreciated. Thanks!

1 Like
#2

Hey there, just create a simulator build with exp build:ios -t simulator and then run it on iPad Simulator. You can change Simulator device type under Hardware -> Device when using the Simulator app.

supportsTablet: false sounds like it’s doing what it’s designed to do - your app isn’t expanding to the iPad viewport and is instead rendering at 2x on iPads. If you want your app to use the full width of the iPad screen, use supportsTablet: true.

1 Like
#3

Hey @ben,

I really appreciate the quick reply! -t simulator is a great idea and I can’t believe I overlooked it :see_no_evil:!

Just so we’re on the same page with supportsTablet: false:

There’s no black border or 1x / 2x mode when running Expo on an iPad Air in Simulator (see screenshots below).

The Apple review did in fact have a black border with 1x / 2x in the bottom right. That’s the part we failed and that’s the part I’m struggling to recreate.

Thanks again!

#4

The Expo Client app can’t change its tablet support on the fly, unfortunately, so it will always adapt your project to the iPad viewport. The best way to test your standalone build settings (including, but not limited to, supportsTablet) is to generate a standalone build, then run it on an iPad or iPad Simulator.

2 Likes
#5

Hey Ben,

Thanks for the help! Building an IPA in simulator mode allowed me to fix the issues.

1 Like
closed #6

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.