Some of your project's dependencies are not compatible with currently installed expo package version

Please provide the following:

  1. SDK Version: ~37.0.3
  2. Platforms(Android/iOS/web/all): iOS

Hello I have created a project using the expo-cli and I want to use react-navigation, but after installing it I am getting the following message when I start my project

Some of your project’s dependencies are not compatible with currently installed expo package version:

  • react-native-reanimated - expected version range: ~1.7.0 - actual version installed: ^1.8.0
  • react-native-screens - expected version range: ~2.2.0 - actual version installed: ^2.7.0
  • @react-native-community/masked-view - expected version range: 0.1.6 - actual version installed: ^0.1.10
    Your project may not work correctly until you install the correct versions of the packages.
    To install the correct versions of these packages, please run: expo install [package-name …]

is there a way to solve it? I understand the expo should work fine with the installed package versions.

Greetings!
Have u already found any solutions?
Because i have the same problem…

Hello,
No, I have not.

Hi! I hve got answer for your question. Each times when you are installing some packges you should install it with command expo install react-native-reanimated.So it will look like expo install < npm package >.

Looks like running expo update will solve it. I don’t see that command mentioned in the docs or help, but I found in on SO and when I ran my dependencies were fixed and the warning is gone.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.