Standalone apk freezes at launch screen

The same problem happen to me, I tried in sdk 27 and 28. The splash screen seems to be covering the main screen and never get hide. What info will be useful for you?

I would like source code that reproduces this problem.

You can check the artifact here https://expo.io/artifacts/f5501180-9067-43bb-acba-d5d2d17cda46
And source code https://github.com/to-em-dia/bugReportExpo

1 Like

Thanks for sending code! That reproduces the issue so I’ll start working on it.

1 Like

if you need my help or more details don`t hesitate to ask.

The workaround of removing the splash screen described here in #2038 worked for me.

This issue also seems to affect iOS, although iOS wasn’t hung at the splash screen, it was able to render my app’s loading spinner post-splash but would not progress any further until the splash screen was removed.

There does seem to be something build-related going on. Even though my APK now works (sans splash screen), it’s loading a module that no longer exists.

I previously had a SomePage.native.js and SomePage.web.js. These were unified into a single cross-platform “SomePage.js” earlier in the week, with multiple subsequent builds working A-OK.

Curiously, now that my app loads thanks to the remove-the-splash-screen workaround, I all of a sudden see the content of the old SomePage.web.js … even though that file definitely no longer exists locally or on my build servers. Oddly, this happens only in the Android app. iOS is A-OK, post-workaround.

Just sharing in case it’s a clue.

Everything was working fine for us until yesterday afternoon or evening, PST.

1 Like

Currently deploying a fix. Will take another ~30 minutes or so before it’s out. Thank you @torico for the source code.

4 Likes

The fix is deployed now, you’ll have to run exp build:android again. Let me know if it isn’t fixed for you.

8 Likes

Hey @jesse, it works :slight_smile: Thank you!

@jesse, it works now. Thanks man!!! :facepunch:

Thank you!

Great! Sorry about that everyone.

Hi Guys… I am now facing this issue.My app works fine in development but in apk it freezes.

Expo version using in this project is 25.0.0

Can anyone suggest me to resolve this?

Facing the same issue. Im on Expo version 28

Hi jesse… But still now i am facing this issue… Changed expo version to 29 and removed splash screen also but the error remains. Can u suggest anything?

hi,

for me the fix worked.

thanks a lot

m.

@kyjak How did u solved ?? Can u say it ? still now i am acing this

hi,

was not me, browse this topic,

someone pushed a fix for expo

and solved the issue for most of us.

m.

Do I need to update my version of expo for the fix to take effect? My apps are currently on 28.0.0

I rolled back my expo version to 27 and seems to be working more reliably now