Standalone app works on older android versions, errors on newer versions

#1

We built a standalone app with Expo and published to the ios app store and the google play store. after release, users with newer devices/android versions were reporting the following error:

Broadcast of Intent { act=com.google.firebase.INSTANCE_ID_EVENT flg=0x14 cmp=com.fillItForward.main/com.google.firebase.iid.FirebaseInstanceIdInternalReceiver launchParam=MultiScreenLaunchParams { mDisplayId=0 mFlags=0 } (has extras) }

com.google.firebase.iid.FirebaseInstanceIdInternalReceiver

Our app does not use firebase as a back end service, but i suspect expo uses it.

I did a little googling, and found this article:

I also dug around in the expo code and found that expo builds target Android SDK v25. It appears that perhaps targeting newer SDKs might resolve our issues.

Target SDK Android
#2

it looks like other users are also awaiting replies for this:

#3

It sounds like the targetSdkVersion could be related. We have an internal issue open to upgrade the targetSdkVersion since Google Play requires v26 by August, but no ETA; we generally announce things when they are ready.

1 Like
closed #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.