Standalone iOS app crashes upon pressing FB Login button

#1

My standalone iOS app launches with Splash Screen -> Login Screen with a facebook login. Upon tapping the FB login button, the app silently crashes (without showing the login prompt). We are currently on Expo SDK 25, but started having this happen on Expo SDK 24 as well.

On Android with a standalone build it works normally.

In production mode on simulators and on device with both iOS and Android, everything works fine.

I see similar issues here (Facebook login crashes in standalone app, https://github.com/expo/expo/issues/1334) but without any resolution.

Any help would be appreciated! Happy to share more details as well about our build. Thanks!

Probably unrelated, but we also get the splash screen improper sizing issue here https://github.com/expo/expo/issues/1322

1 Like
#2

Hi @mikesholiu - thanks for reporting this issue. We’ll track it on the github ticket you linked, so you can watch for further information there!

#4

Thanks @esamelson. We tried it on another old working build on Expo 24 and the same crash happens.

We are working on getting a big new update out to our users and this is a blocker for us – in case that helps with prioritization :slight_smile: !

#5

@esamelson @aalices Here is the unsymbolicated crash report for this issue from my device. Hopefully it is helpful in tracking down the issue. https://www.dropbox.com/s/c1zkpnvqe709aq4/ExpoKitApp-2018-01-27-104737.ips.beta?dl=0

closed #6

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.