Strange build/deployment errors in sdk 27

#1

I have a standalone, non-detached app that has been in production for the last few months. I recently updated to sdk 27 and ran exp build:ios --release-channel <CHANNEL> to build the ipa. I then uploaded the ipa to test it via test flight.

  1. When I updated my app from test flight, I got the “There was a problem loading the requested app…” I’ve only seen this error on the expo client app when it is out of date. Why am I seeing this on a standalone build?

  2. I decided to rebuild, redeploy, and install once again via test flight. The version number is updated and everything looks good, except this version of my app is 2 weeks old. It doesnt have my latest changes. The latest changes do show up in the simulator, so they should be in the js bundle.

#2

@djangojack Did you add FCM support in your app.json? I am experiencing similar error during development.

#3

Hi @djangojack – sorry for the confusion. We have been unable to deploy our servers for building iOS apps for SDK 27 yet (this was mentioned at the top of our blog post) so when you run exp build:ios you’re still just getting an older version of your app. (We should probably have an error message for this, sorry!)

The fact that we have been unable to deploy so long after releasing SDK 27 is unusual for us and is partly due to Apple TestFlight being down, leaving us unable to fully QA our builders. We’re hoping to deploy later today, at which point you should be able to build an SDK 27 standalone ipa as normal. I would suggest refreshing the blog post every so often to see if the message is gone. We’re really sorry for the inconvenience.

1 Like
#4

Thanks @esamelson. I completely missed that note.

#5

I see that the note was removed from the blog post, but I still had the same issue. I rebuilt the ipa, uploaded, pulled down from test flight, and it was an old version of my app. Any ideas?

#6

Hi @djangojack - I’m re-reading your post again and see the part where you said the version number is updated but the code is old. Which version number do you mean – the version in your app.json? If that’s the case, it seems that old code is getting published with a new version number each time you run exp build:ios.

Another question – have you tried fully uninstalling the old version of your app from your device before installing the updated build from testflight?

#7

@esamelson - when I say that the version number is updated, I’m referring to the version and buildNumber from my app.json.

And I tried completely uninstalling and reinstalling via test flight and it worked. Might have been user error… not sure :smile:

#8

Hi @djangojack - glad to hear it’s fixed! We’ll do some more testing internally to see if we can replicate the issue you were seeing.

#9

@djangojack This might not have been fixed. See if you are experiencing the same issue as me do?

closed #10

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.