String violation error in app.json...is it a mistake?

My IDE is throwing this error. Seems like it’s not allowing A-F for hex codes. Is this an IDE or Expo issue?

Expo: SDK 39 managed.

That is correct. You should not worry about it.
My PHPStorm does not highlight it and I have it like this "color": "#FFBB00" working ok.
Not sure what IDE you are using

I’m using RubyMine (JetBrains) so seems to be a JetBrains issue…

PHPStorm is JetBrains as well. I think it is just an IDE config issue.