Stuck at Downloading JavaScript bundle 100.0%


#1

hi everyone,

i somehow managed to break my expo project. i installed a npm package (redux-thunk), added some lines in my root component - now it is stuck at „downloading JavaScript bundle 100.0%“; no errors.

i did a git hard reset, rm -rf node_modules, updated to sdk 21, tried it both on simulator and device via tunnel and lan, xde and cli.

any advice on what might cause this is highly appreciated, thank you!!


#2

Did you try to remove that some line of codes you added in and see your problem still persist? if the problem is solved, that some line of codes is the source of error.


#3

hi tanvi,

thanks for your reply. yes, i did a git reset to a previous version that was working, problem persists.


#4

This is most likely some kind of infinite loop that your app is getting itself into.

I would definitely strip your app down to it’s barebones – just render a small thing at the root. Gradually add back components and basically perform a binary search across your codebase for the issue (adding logs anywhere you might need).


#5

skevy, thank you. rebuilding it bit by bit led me to the line that was causing the loop. still not sure what the actual problem is (line is just a simple async function), but i’ll figure it out. cheers


#6

Skevy, thank you, follow your advice I find the infinite loop. Never a good idea of using while loop in js.