stuck on starting metro bundler

Hello team,
I’m new to expo. When I am trying to start expo, is started on CMD and shows me the QR code
but on the localhost page it says Starting Metro Bundler and stuck on it.

expo diagnostics are
Expo CLI 3.27.7 environment info: System: OS: Windows 10 10.0.18363 Binaries: Node: 14.11.0 - C:\Program Files\nodejs\node.EXE npm: 6.14.8 - C:\Program Files\nodejs\npm.CMD npmPackages: expo: ~39.0.2 => 39.0.3 react: 16.13.1 => 16.13.1 react-dom: 16.13.1 => 16.13.1 react-native: https://github.com/expo/react-native/archive/sdk-39.0.2.tar.gz => 0.63.2 react-native-web: ~0.13.12 => 0.13.13 Expo Workflow: managed

please help to get rid of this. I tried to restart computer. multiple times tried to start expo but no result.

2 Likes

iam having the same problem :slight_smile: Can someone help, pls?!

Same here, can anyone help please??

could you try EXPO_USE_DEV_SERVER=1 expo start and see if that helps?


Tryied, and this appeared…

i see, that is the unix format of setting an environment variable. so, however you do it on windows, set EXPO_USE_DEV_SERVER=1 and then run expo start again

I put EXPO_USE_DEV_SERVER=1 into .env file then used expo start and it’s stucked in the same place… :confused:

“Starting Metro Bundler” and nothing…

Facing the same issue, did you find any fix?

On windows you can stuck npx cross-env to the start of the linux command and it will correctly parse the environment variables

I have the exact same issue on MBP 2019.
Worked like a charm until one day it stopped on “starting metro bundler” for all projects.

Expo CLI 3.28.5 environment info:
System:
OS: macOS 10.15.7
Shell: 5.7.1 - /bin/zsh
Binaries:
Node: 12.18.4 - ~/.nvm/versions/node/v12.18.4/bin/node
Yarn: 1.22.5 - ~/.yarn/bin/yarn
npm: 6.14.6 - ~/.nvm/versions/node/v12.18.4/bin/npm
Watchman: 4.9.0 - /usr/local/bin/watchman
IDEs:
Xcode: /undefined - /usr/bin/xcodebuild
npmPackages:
expo: ~39.0.2 => 39.0.4
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: https://github.com/expo/react-native/archive/sdk-39.0.4.tar.gz => 0.63.2
react-native-web: ~0.13.12 => 0.13.18
npmGlobalPackages:
expo-cli: 3.28.5
Expo Workflow: managed

I’m having the same problem as the others!