Switching off caching in iOS simulator

Please provide the following:

  1. SDK Version: 3.28.5
  2. Platforms(Android/iOS/web/all): iOS Simualtor

I am testing the app on my 1) Android 10 device and 2) iOS simulator on my macOS.
When I edit the code and save the iOS simulator refreshes immediately but the Android device takes a few seconds to refresh as it re-downloads the JavaScript bundle.
As a result I find that the iOS simulator caches the content as, if I fix a bug, it still shows the error message on the simulator but works correctly now on my Android device.

Is there a caching setting I can switch off in the simulator ?

i believe you are referring to “fast refresh” - you can read more about this here: https://reactnative.dev/docs/fast-refresh

So how do I disable this in expo ?

the same way you would in react-native without using expo - open the developer menu and press disable fast refresh

Thank you. I’m currently exploring React Native through expo only, via a Udemy tutorial.

cool :slight_smile: be sure to refer to the docs when you have any questions that aren’t answered by the course: https://docs.expo.io/

have fun!

1 Like

Thank you very much. I am also looking for the same. Can some one please respond.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.