The bundle is invalid. CFBundleShortVersionString must be higher


#1

Hi,

I recently tried to follow the channel release feature (https://docs.expo.io/versions/v27.0.0/distribution/release-channels) with Expo and came up with this error while trying to add an .ipa with Application Loader.

ERROR ITMS-90062: “This bundle is invalid. The value for key CFBundleShortVersionString [1.5.0] in the Info.plist file must contain a higher version than that of the previously approved version [1.13.2].”

In my app.json, I have "version": "1.5.0" , "buildNumber" : "1.5.0",.

I also made sure that those versions were higher than the previous ones.

I ran exp build:ios --release-channel staging to get my .ipa.

Am I doing something wrong or missing something?

Thank you!
Thierry


#2

Hi Thierry,

Hmm, it looks like App Loader is seeing the version you would expect after the build, but Apple thinks they have already approved an app with version 1.13.2. I suspect if you bumped the version to 1.13.3 or higher and rebuilt you would be able to submit, but couldn’t tell you where the 1.13.2 build came from.

Hope that helps,
TC


closed #3

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.