The experience you requested uses Expo SDK v26.0.0, but requires v27.0.0

Hello.
I have a project, which was write with expo sdk 25.0.0.
But now I need feature “updates” in app.json for the “first offline open”, so I migrate project to expo sdk 26.0.0 and then, to 27.0.0.
I build a new version of standalone app and upload it to the TestFlight.
When i open TestFlight, i get an error:

The experience you requested uses Expo SDK v26.0.0, but this copy of Expo Client requires at least v27.0.0. The author should update their experience to a newer Expo SDK version.

I removed node_modules/ , cleaned cache of yarn and npm, deleted package-lock.json, yarn-lock.json.
I cloned project to a new folder, and still no result.
The same error.
In Xcode, the expo plist files contains correct (27) sdk version.
The app.json and package.json are contain the correct version too. I can’t understand where I need to fix Expo SDK version.

app.json:

{
  "expo": {
    "name": ***,
    "slug": ***,
    "version":"2018.05.08",
    "sdkVersion": "27.0.0",
    "platforms": ["ios", "android"],
    "orientation": "portrait",
    "privacy": "unlisted",
    "icon": "./App/Assets/Images/appIcon.png",
    "splash": {
      "image": "./App/Assets/Images/loadingIcon.png"
    },
    "ios": {
      "supportsTablet": true,
      "bundleIdentifier": ***
    },
    "updates": {
      "enabled": false,
      "fallbackToCacheTimeout": 0
    },
    "android": {
      "package": ***,
      "versionCode": 17,
      "permissions": [
        "CAMERA",
        "CAMERA_ROLL",
        "READ_INTERNAL_STORAGE",
        "READ_EXTERNAL_STORAGE",
        "WRITE_EXTERNAL_STORAGE",
        "com.android.launcher.permission.INSTALL_SHORTCUT",
        "com.android.launcher.permission.INSTALL_SHORTCUT"
      ]
    },
    "assetBundlePatterns": [
      "App/Assets/**",
      "App/Assets/Images/**",
      "Images/**",
      "App/Fonts/*.ttf",
      "node_modules/react-navigation/src/**/*.png"
    ]
  }
}

package.json:

{
  "main": "node_modules/expo/AppEntry.js",
  "scripts": {
    "start": "react-native-scripts start",
    "eject": "react-native-scripts eject",
    "android": "react-native-scripts android",
    "ios": "react-native-scripts ios",
    "test": "node node_modules/jest/bin/jest.js --watch",
    "localhost": "set REACT_NATIVE_PACKAGER_HOSTNAME=192.168.111.140&& npm start"
  },
  "devDependencies": {
    "jest-expo": "^26.0.0",
    "react-native-scripts": "1.7.0",
    "react-test-renderer": "16.0.0-beta.5",
    "reactotron-apisauce": "^1.12.2",
    "reactotron-react-native": "^1.12.3"
  },
  "jest": {
    "preset": "jest-expo"
  },
  "private": true,
  "dependencies": {
    "expo": "^27.0.1",
    "react": "16.3.1",
    "react-native": "https://github.com/expo/react-native/archive/sdk-27.0.0.tar.gz",
    "d3-color": "^1.0.3",
    "i18next": "^10.2.2",
    "mobx": "^3.4.1",
    "mobx-react": "^4.3.5",
    "mobx-state-tree": "^1.3.1",
    "moment": "^2.20.1",
    "prop-types": "^15.6.0",
    "react-i18next": "^7.3.1",
    "react-native-action-button": "^2.8.3",
    "react-native-elements": "^0.19.0",
    "react-native-image-gallery": "^2.1.5",
    "react-native-keyboard-aware-scroll-view": "^0.4.3",
    "react-native-modal-datetime-picker": "^4.13.0",
    "react-native-popup-menu": "^0.12.2",
    "react-native-svg-uri": "^1.2.3",
    "react-navigation": "1.0.0-beta.21"
  }
}

You say: “In Xcode, the expo plist files contains correct (27) sdk version.”
Does this mean the project is detached?
If so you will need to update the native modules as well.

Yes, project is detached.
Is “Update native modules” mean, that i need to recreate ios folder?

Read the “Upgrading Your App” section:
https://blog.expo.io/expo-sdk-v27-0-0-is-now-available-898bf1e5b0e4
:blue_heart::blue_heart::blue_heart::blue_heart:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.