The expo Sdk requires expo to run


#1

Environment

  • expo : 30.0.1
  • expokit: 1.7.1

I detached my app to expo kit and am running into this error while trying to run my app in android.

The app works fine in IOS - can anyone point me in the right direction? I’ve created a fresh expo project and detached to see if I run into a similar issue, but it works fine in a fresh app - so the problem might be with a configuration option I have in android? I’m not even sure where to start looking. Also the android version of my app was working fine when I was on expo 25. I just upgraded to expo 30. Any guidance is appreciated, thanks.


#2

Ive noticed the expokit upgrade instructions include this

` Change all instances of  `android\detach-scripts`  and  `android/detach-scripts`  to  `node_modules\expokit\detach-scripts`  and  `node_modules/expokit/detach-scripts`  respectively in  `android/app/expo.gradle``

But when upgrading from 25 to 30 - the expo.gradle file doesn’t in fact exist.


closed #3

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.