The "ExpoNativeModulesProxy" native module is not exported through NativeModules;

I have e warning Message while running Expo.
The “ExpoNativeModulesProxy” native module is not exported through NativeModules; verify that expo-react-native-adapter’
s native code is linked properly

  • node_modules\react-native\Libraries\YellowBox\YellowBox.js:67:8 in warn
  • node_modules\expo\build\environment\muteWarnings.fx.js:17:23 in warn
  • node_modules\expo-react-native-adapter\build\NativeModulesProxy.js:28:4 in
  • node_modules\metro\src\lib\polyfills\require.js:331:6 in loadModuleImplementation
  • node_modules\expo-react-native-adapter\build\index.js:3:0 in
  • node_modules\metro\src\lib\polyfills\require.js:331:6 in loadModuleImplementation
  • node_modules\expo-core\build\index.js:1:0 in
  • node_modules\metro\src\lib\polyfills\require.js:331:6 in loadModuleImplementation
  • assets\StyleCss\StylePage.js:2:0 in
  • node_modules\metro\src\lib\polyfills\require.js:331:6 in loadModuleImplementation
  • screens\ForgetPassword.js:6:0 in
  • node_modules\metro\src\lib\polyfills\require.js:331:6 in loadModuleImplementation
  • navigation\AppNavigator.js:25:0 in
  • node_modules\metro\src\lib\polyfills\require.js:331:6 in loadModuleImplementation
  • App.js:4:0 in
  • node_modules\metro\src\lib\polyfills\require.js:331:6 in loadModuleImplementation
  • node_modules\expo\AppEntry.js:4:0 in
  • node_modules\metro\src\lib\polyfills\require.js:331:6 in loadModuleImplementation
  • node_modules\metro\src\lib\polyfills\require.js:197:45 in guardedLoadModule
  • null:null in global code

Expo sdk :
“sdkVersion”: “34.0.0”,
“react”: “16.8.3”,

Hey @ritesh.paryali,

Just to be certain, is this project a Managed project?

Cheers,
Adam

I am receiving this same error message, The "ExpoNativeModulesProxy" native module is not exported through NativeModules; verify that expo-react-native-adapter's native code is linked properly, after updating to CLI 3.0.9 and SDK 34. Not sure if it is related but I am also receiving this error, TypeError: asset.downloadAsync is not a function. (In 'asset.downloadAsync()', 'asset.downloadAsync' is undefined), after updating as well. Had not seen either of these issues until updating. Have tried with both Node 10 and 12, same behavior for both. Any ideas?
Expo CLI 3.0.9 environment info:
System:
OS: macOS 10.14.6
Shell: 5.3 - /bin/zsh
Binaries:
Node: 12.8.0 - ~/.nvm/versions/node/v12.8.0/bin/node
Yarn: 1.17.3 - /usr/local/bin/yarn
npm: 6.10.2 - ~/.nvm/versions/node/v12.8.0/bin/npm
IDEs:
Android Studio: 3.1 AI-173.4670197
Xcode: 10.3/10G8 - /usr/bin/xcodebuild
npmPackages:
expo: ^34.0.3 => 34.0.4
react: 16.8.3 => 16.8.3
react-native: https://github.com/expo/react-native/archive/sdk-34.0.0.tar.gz => 0.59.8
react-navigation: ^2.18.2 => 2.18.3
npmGlobalPackages:
expo-cli: 3.0.9

About the second problem, see this comment from @charliecruzan:

@wodin Thanks for the reply. Yes I have made the changes to my imports, and have run expo install expo asset.

1 Like

Finally found the issue for the downloadAsync(), and it wasn’t even close to what I thought. Our home screen background image wasn’t being preloaded so I thought the issue was in the image loadAsync() function, but it was actually being caused by the fonts loadAsync function, more specifically loading "Ionicons": require("@expo/vector-icons"). Changing that line to ...Ionicons.font solved the problem and I am no longer seeing the error. Still have no idea about the NativeModule issue, will post back if I find the cause of that one.