"There was an error with this build" (IOS)

#1

same error as here
but probably another reason
[exp] Build ID: 44244733-f28c-4ff6-acef-b325edce4802

building for simulator works fine

my app.json

{
  "expo": {
    "name": "Dance & Deals",
    "description": "Dance And Deals Application",
    "slug": "dance-deals-rn-app",
    "privacy": "unlisted",
    "sdkVersion": "19.0.0",
    "version": "0.1.0",
    "orientation": "portrait",
    "primaryColor": "#B47A1A",
    "icon": "./assets/icons/app.png",
    "loading": {
      "icon": "./assets/icons/loading.png",
      "hideExponentText": true,
      "backgroundColor": "#B47A1A"
    },
    "packagerOpts": {
      "assetExts": [
        "ttf",
        "mp4"
      ]
    },
    "ios": {
      "bundleIdentifier": "com.itsource.danceanddeals"
    },
    "android": {
      "package": "com.itsource.danceanddeals"
    },
    "facebookScheme": "fb422559601459258"
  }
}

removed backgroundColor under loading (splashscreen ?) didn’t work
@dikaiosune can you look at my server build logs ? thanks alot

#2

@flieks did you upload your own distribution certificate or let Expo generate it for you? It seems like whatever distribution cert we have for you is invalid.

#3

Thanks @skevy I let expo generate it for me… I’m not expert in ios native dev. Should i make my own cert?