Things need to prepare before upgrading Expo SDK

Hi All,

Hope that everyone doing well! So we had an app that builds with the below SDK specs:

  1. SDK Version: 36
  2. Platforms(Android/iOS/web/all): Android/iOS
  3. Add the appropriate “Tag” based on what Expo library you have a question on.

I would like to ask anyone in this forum regarding anything that must be prepared before upgrading Expo SDK? Because we have a plan to upgrade our project’s SDK version from 36 to 41.

Best regards.
Tommy

Hey @tommycp, I would strongly suggest reading our Changelog specifically for breaking changes but also for any changes to modules you use in your app.

Another good idea, if time permits, is to incrementally upgrade so if problems arise you can more quickly identify what is causing the issue.

Cheers,
Adam

how does one incrementally upgrade? I went from sdk 39 o 41 and now expo start wont work

.

Thanks