Trying to setup Google/Facebook sign on

#1

The instructions read like this:

Get an app set up on the Google Developer Console

Go to the Credentials Page
Create an app for your project if you haven’t already.
Once that’s done, click “Create Credentials” and then “OAuth client ID.” You will be prompted to set the product name on the consent screen, go ahead and do that.

But all of that brings me to these input fields:

I can’t really answer those questions because I don’t have a AndroidManifest.xml…
I could use a little bit clearer instruction on https://docs.expo.io/versions/latest/sdk/google.html#get-an-app-set-up-on-the-google-developer-console

Or maybe I just need to be smarter.

#2

hey! no worries man, it gets confusing setting up all these configuration files :sweat_smile:

have you already build a standalone android app? if so, you can go to your app.json file and look at the package name under android.

if not, you need to make an app and set this value in your app.json file

#3

When I quit trying to read the instructions linearly, it makes a bit more sense, but this line could use a bit more clarification.

I think I’ve now got it setup for android and apple (still haven’t built the standalone app, still using expo during development) but a screen shot or two in the docs would make a world of difference.

Another thing that might be very helpful (since most of the instructions out there deal with .plist and AndroidManifest.xml files is to actually create and maintain those files with the correct values for an expo based client app. Throw a comment at the top that those files are autogenerated and changes will be overwritten, but create them so when reading the docs about how to do things, those files give you the values you need to know.