Tunnel error after exp start

#1

Hello. Last days I started getting this error after exp start.
I can’t connect from the simulator at all, but when I add the --offline flag it seems to work fine. Can it be related to the latest outage?

[exp] Error starting tunnel: XDLError: TypeError: Cannot read property 'toLowerCase' of undefined
[exp] Switched to a LAN URL because the tunnel appears to be down. Only devices in the same network can access the app. Restart with `exp start` to try reconnecting.

My package.json

{
  "name": "native",
  "version": "0.0.3",
  "description": "xxx",
  "author": null,
  "main": "main.js",
  "scripts": {
    "clean-install": "watchman watch-del-all; rm -rf $TMPDIR/react-*; rm -Rf node_modules; npm install",
    "test": "node_modules/jest/bin/jest.js",
    "devtools": "react-devtools"
  },
  "jest": {
    "preset": "jest-expo"
  },
  "dependencies": {
    "@expo/ex-navigation": "^2.9.4",
    "@expo/samples": "~1.0.2",
    "@expo/sentry-utils": "^0.2.0",
    "@expo/vector-icons": "^5.0.0",
    "apollo-client": "^1.0.4",
    "apollo-link-core": "^0.5.0",
    "babel-jest": "^20.0.3",
    "babel-preset-decorators-legacy": "^1.0.0",
    "babel-preset-es2015": "^6.22.0",
    "babel-preset-stage-2": "^6.22.0",
    "d3": "^4.5.1",
    "expo": "^19.0.0",
    "graphql": "^0.9.3",
    "graphql-tag": "^2.0.0",
    "hoist-non-react-statics": "^1.2.0",
    "immutability-helper": "^2.1.2",
    "jest-expo": "~19.0.0",
    "lodash": "^4.17.4",
    "moment": "^2.17.1",
    "moment-timezone": "^0.5.11",
    "numbro": "^1.9.3",
    "prop-types": "^15.5.10",
    "ramda": "^0.23.0",
    "raven-js": "^3.10.0",
    "react": "16.0.0-alpha.12",
    "react-addons-update": "^15.4.2",
    "react-apollo": "^1.1.0",
    "react-dom": "^15.4.2",
    "react-native": "https://github.com/expo/react-native/archive/sdk-19.0.0.tar.gz",
    "react-native-animatable": "^1.2.3",
    "react-native-circular-progress": "0.0.8",
    "react-native-drawer": "^2.5.0",
    "react-native-exception-handler": "^1.1.0",
    "react-native-form": "^2.1.2",
    "react-native-interactable": "^0.1.3",
    "react-native-keyboard-spacer": "^0.3.1",
    "react-native-looped-carousel": "^0.1.7",
    "react-native-meteor": "1.1.0",
    "react-native-popup-dialog": "^0.9.35",
    "react-native-swipe-gestures": "^1.0.2",
    "react-native-tabs": "^1.0.9",
    "recompose": "^0.21.2",
    "sentry-expo": "~1.6.0",
    "uglify-js": "2.8.5",
    "underscore": "^1.8.3"
  },
  "devDependencies": {
    "@storybook/addon-storyshots": "^3.2.5",
    "babel-eslint": "^6.1.2",
    "eslint": "^3.14.0",
    "eslint-config-airbnb": "^9.0.1",
    "eslint-import-resolver-meteor": "^0.2.4",
    "eslint-plugin-import": "^1.13.0",
    "eslint-plugin-jest": "^20.0.3",
    "eslint-plugin-jsx-a11y": "^1.5.5",
    "eslint-plugin-react": "^5.2.2",
    "eslint-plugin-react-native": "^2.2.1",
    "exp": "^32.3.0",
    "react-devtools": "^2.5.2"
  }
}

I removed .expo dir, reinstalled all node modules, restarted simulator but nothing works :frowning:

#2

Can you share the specific URLs you are seeing? Also, on some computers – esp. Windows machines – I’ve seen restarting the computer sometimes fix issues like this. Can you try that if you haven’t?

We had some login and auth problems a few hours ago. They should be resolved now but if you opened xde or exp or CRNA before that was resolved, then that could be part of the problem.

#3

It just gives me url like this: exp://192.168.0.103:19000
Before it was a tunneled URL. Working from mac. Restarted with no effects.
It seems, that I can now develop without the --ofline flag but the tunel error is still there, maybe they are not connected at all.

#4

what version of exp do you have? maybe try reinstalling that?

#5

actually i think what you’ll need to do is exp logout and then exp login.
i think somehow what happened is that you got recorded as logged in as “undefined” during our authorization outage. really sorry about that. can you let me know if that works?

#6

This Tunel issue is always appearing to me. @ccheever Is there anything i can do to minimize this issue?
Thanks!

#7

@yoohood

If the tunnel is not working well for you, I would switch to using the LAN option and connect your phone to the same wifi network as your computer.