Unable to expo build:ios

Thanks a lot @aleksczajka.

expo upload:ios --apple-id [your user name] --apple-id-password [your password] works great.

Had the same error.
I think it’d make sense if expo upload:ios react immediately and give the error before downloading the file. :slight_smile:

Hi Guys,

I have been having the similar issue. I run npm run build-android and it works and gives me url to download the apk. When I sun npm run build-ios, I get the following error.

Trying to authenticate with Apple Developer Portal…
getaddrinfo: nodename nor servname provided, or not known
Authentication with Apple Developer Portal failed!
Reason: Unknown reason, raw: “Could not receive latest API key from App Store Connect, this might be a server issue.”
Set EXPO_DEBUG=true in your env to view the stack trace.
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! @ build-ios: expo build:ios
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the @ build-ios script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

After going throuhg above comments I ran expo digonostics from my cli and I got below info.

Expo CLI 3.0.9 environment info:
System:
OS: macOS 10.14.6
Shell: 3.2.57 - /bin/bash
Binaries:
Node: 8.11.4 - /usr/local/bin/node
npm: 5.6.0 - /usr/local/bin/npm
IDEs:
Xcode: /undefined - /usr/bin/xcodebuild
npmPackages:
expo: ^33.0.0 => 33.0.7
react: 16.8.3 => 16.8.3
react-native: https://github.com/expo/react-native/archive/sdk-33.0.0.tar.gz => 0.59.8

Please help as I stuck for past few days now. :frowning:

Please try upgrading expo-cli.

Thanks @wodin . That worked like a charm.

1 Like

the problem here was with expo build:ios and not the upload part. I am still having the issue with the exp build:ios and having the problem:

[22:18:24] Error while gathering & validating credentials

[22:18:24] Reason:Unknown reason, raw:“Could not receive latest API key from iTunes Connect, this might be a server issue.”

[22:18:24] Set EXPO_DEBUG=true in your env to view the stack trace.

Here i my diagnostics:

Expo CLI 3.11.0 environment info:
System:
OS: macOS 10.14.6
Shell: 3.2.57 - /bin/bash
Binaries:
Node: 12.13.0 - /usr/local/bin/node
npm: 6.12.0 - /usr/local/bin/npm
Watchman: 4.9.0 - /usr/local/bin/watchman
IDEs:
Android Studio: 3.2 AI-181.5540.7.32.5056338
Xcode: 10.1/10B61 - /usr/bin/xcodebuild
npmPackages:
expo: ^35.0.0 => 35.0.1
react: 16.8.3 => 16.8.3
react-native: https://github.com/expo/react-native/archive/sdk-35.0.0.tar.gz => 0.59.8
react-navigation: ^4.0.10 => 4.0.10
npmGlobalPackages:
expo-cli: 3.11.0