Unable to resolve module './debugger

After a reload my app has stopped loading.

I have tried on both emulators and 2 real devives, android and ios.

The error is:

Error: Unable to resolve module ./debugger-ui/debuggerWorker.d9da4ed7 from ``:

and occassionally I will get the error, ‘unable to locate instance’.

I have tried the following:

  1. Clear watchman watches: watchman watch-del-all .
  2. Delete the node_modules folder: rm -rf node_modules && npm install .
  3. Reset Metro Bundler cache: rm -rf /tmp/metro-bundler-cache-* or npm start -- --reset-cache .
  4. Remove haste cache: rm -rf /tmp/haste-map-react-native-packager-* .
  5. Restart the computer.

Expo CLI 3.11.3 environment info:
System:
OS: macOS 10.15.2
Shell: 5.7.1 - /bin/zsh
Binaries:
Node: 12.8.0 - ~/.nvm/versions/node/v12.8.0/bin/node
Yarn: 1.19.1 - /usr/local/bin/yarn
npm: 6.13.4 - ~/.nvm/versions/node/v12.8.0/bin/npm
Watchman: 4.9.0 - /usr/local/bin/watchman
IDEs:
Android Studio: 3.5 AI-191.8026.42.35.5791312
Xcode: 11.2/11B41 - /usr/bin/xcodebuild
npmPackages:
expo: ~36.0.0 => 36.0.2
react: ~16.9.0 => 16.9.0
react-native: https://github.com/expo/react-native/archive/sdk-36.0.0.tar.gz => 0.61.4
react-navigation: ^4.0.10 => 4.0.10
npmGlobalPackages:
expo-cli: 3.11.3

Any ideas on what else I can try to resolve this?

The full error below:


Error: Unable to resolve module `./debugger-ui/debuggerWorker.d9da4ed7` from ``:

None of these files exist:
  * debugger-ui/debuggerWorker.d9da4ed7(.native|.native.expo.ts|.expo.ts|.native.expo.tsx|.expo.tsx|.native.expo.js|.expo.js|.native.expo.jsx|.expo.jsx|.native.ts|.ts|.native.tsx|.tsx|.native.js|.js|.native.jsx|.jsx|.native.json|.json|.native.wasm|.wasm)
  * debugger-ui/debuggerWorker.d9da4ed7/index(.native|.native.expo.ts|.expo.ts|.native.expo.tsx|.expo.tsx|.native.expo.js|.expo.js|.native.expo.jsx|.expo.jsx|.native.ts|.ts|.native.tsx|.tsx|.native.js|.js|.native.jsx|.jsx|.native.json|.json|.native.wasm|.wasm)
    at ModuleResolver.resolveDependency (/Users/serdarmustafa/task_location_namespace/node_modules/metro/src/node-haste/DependencyGraph/ModuleResolution.js:163:15)
    at ResolutionRequest.resolveDependency (/Users/serdarmustafa/task_location_namespace/node_modules/metro/src/node-haste/DependencyGraph/ResolutionRequest.js:52:18)
    at DependencyGraph.resolveDependency (/Users/serdarmustafa/task_location_namespace/node_modules/metro/src/node-haste/DependencyGraph.js:282:16)
    at /Users/serdarmustafa/task_location_namespace/node_modules/metro/src/lib/transformHelpers.js:267:42
    at /Users/serdarmustafa/task_location_namespace/node_modules/metro/src/Server.js:1305:37
    at Generator.next (<anonymous>)
    at asyncGeneratorStep (/Users/serdarmustafa/task_location_namespace/node_modules/metro/src/Server.js:99:24)
    at _next (/Users/serdarmustafa/task_location_namespace/node_modules/metro/src/Server.js:119:9)
    at processTicksAndRejections (internal/process/task_queues.js:85:5)
1 Like

I’m getting the same error, but it has to do with the element inspector.

If I toggle element inspector off it works for me

I updated react-devtools v3, but it seems to be something within the inspector itself

I’m on Expo SDK 36.0.1

Any ideas ?

1 Like

I have the same problem. Been trying to fix it for days. Tried everything. Nothing works. :cry: :cry: :cry:

1 Like

Same problem here!! Been having the issue for the past week after upgrading from Expo SDK 35 -> 38.

“expo”: “~38.0.8”,
“react”: “~16.11.0”,
“react-native”: “https://github.com/expo/react-native/archive/sdk-38.0.1.tar.gz”,

@notbrent

Hi Brent - you have always provided the best help on these types of issues. Have you seen this one? Seems like there is no solution on any of the blogs.

Appreciate your help in advance.

Thanks!!