Unable to test / use app on Android devices

#1

Hey guys, I am a big advocate of Expo and am trying to get my company to adopt Expo for all of their mobile apps going forward. But I’m encountering an issue that I haven’t seen before, and wondering if anyone here can help me out.

I just built an app that works really well on iOS. However, it fails to even open on Android, whether I am testing or it is a published build.

While testing, I have tried both LAN and tunnel methods for connection, neither work. I get this error Uncaught Error: java.net/NoRouteToHostException; No route to host. My device and laptop are on the same wifi.

Using a published version of the app, it fails as soon as I attempt to log in via the Google API from Expo. It simply says that the “Expo has stopped” without any other error message.

My app.json file is pretty bare bones. Could this issue have to do with permissions? Have you guys seen a similar issue before?

Thanks a lot for your help.

#2

Any ideas? This is pretty time sensitive.

#3

Hi @prodteam - sounds like you have two separate errors going on here. I’ll try to address them both.

Re: the issue connecting in dev mode, do you have a firewall that might be preventing the device from connecting properly to your computer? The Android docs for this error say that

Signals that an error occurred while attempting to connect a socket to a remote address and port. Typically, the remote host cannot be reached because of an intervening firewall, or if an intermediate router is down.

so I would suspect a firewall is the problem. I would check your firewall settings, and you might also try connecting on a different Wifi network to see if you get different results.

Re: the google login crash, did you follow all of the steps to properly set up your app.json? If not, try doing that first. If you still get a crash, could you try running adb logcat with your device connected to your machine, trigger the crash and paste the native exception/stacktrace here?

closed #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.