Undefined is not an object (evaluating 'nativeVersion.major')


#1

hey there. I need help on starting a react app on Expo
I caught the following error: undefined is not an object evaluating nativeVersion. I tried to update all packages and node version, as i saw on this topic: https://github.com/viromedia/viro/issues/41. But didnt work.
I dont know what to do.
Does have anyone an idea and could help me?

@edit
Im adding some more informations:
package.json:

{
    "name": "test",
    "version": "0.1.0",
    "private": true,
    "devDependencies": {
        "jest-expo": "^23.0.0",
        "react-native-scripts": "^1.5.0",
        "react-test-renderer": "^16.0.0"
    },
    "main": "./node_modules/react-native-scripts/build/bin/crna-entry.js",
    "scripts": {
        "start": "react-native-scripts start",
        "eject": "react-native-scripts eject",
        "android": "react-native-scripts android",
        "ios": "react-native-scripts ios",
        "test": "node node_modules/jest/bin/jest.js --watch"
    },
    "jest": {
        "preset": "jest-expo"
    },
    "dependencies": {
        "@expo/vector-icons": "^6.2.0",
        "axios": "^0.17.1",
        "expo": "^23.0.2",
        "intl": "^1.2.5",
        "lodash": "^4.17.4",
        "native-base": "^2.3.3",
        "prop-types": "^15.6.0",
        "react": "^16.1.1",
        "react-native": "^0.50.3",
        "react-native-communications": "^2.2.1",
        "react-native-easy-grid": "^0.1.15",
        "react-navigation": "^1.0.0-beta.13",
        "react-redux": "^5.0.6",
        "redux": "^3.7.2",
        "redux-form": "^7.1.1",
        "redux-saga": "^0.16.0"
    }
}

#2

not sure what you’re doing when starting this project but it’s almost certainly not the right thing :stuck_out_tongue: just run exp init SomeProject or download xde and create a new project


#3

Yeah man, with a new project it works. But i have an older project which is not working.
Thks for the reply


#4

make sure the dependencies are set correctly in package.json and that the sdkVersion is set correctly in app.json


#5

Well, the problem is solved. After all I had to update all packages, node and expo and update the SDK version.
Thks @notbrent
Could you explain where I can check the compatibility between expo and SDK´s versions?
Now I am getting a new error, because react has not backward compatibility and I have to migrate my project.
But I will open a new topic about this.