Unsupported SDK version: our app builders don't have support for 35.0.0 version yet.

Get this error after changing the version:

 "android": {
      "versionCode": 10101
 }

Unsupported SDK version: our app builders don’t have support for 35.0.0 version yet. Submitting the app to the Apple App Store may result in an unexpected behaviour

Expo CLI 3.4.1 environment info:
System:
OS: macOS 10.14.6
Shell: 5.3 - /bin/zsh
Binaries:
Node: 12.10.0 - /usr/local/bin/node
Yarn: 1.19.0 - /usr/local/bin/yarn
npm: 6.12.0 - ~/.npm-global/bin/npm
IDEs:
Android Studio: 3.3 AI-182.5107.16.33.5314842
Xcode: 11.1/11A1027 - /usr/bin/xcodebuild
npmPackages:
expo: ^35.0.0 => 35.0.0
react: 16.8.3 => 16.8.3
react-native: https://github.com/expo/react-native/archive/sdk-35.0.0.tar.gz => 0.59.8
react-navigation: ^4.0.10 => 4.0.10
npmGlobalPackages:
expo-cli: 3.4.1

I get the same error with Expo CLI 3.4.0.

Similar errors were reported before:

1 Like

I am having the same problem.

It was working properly a few minutes ago. Not sure if related, but I upgraded npm and it seems like expo build:ios stopped working right after.

1 Like

It’s not related. I successfully built 5 hours ago and literally only changed the app.json version number fields & am now encountering the same error with an identical codebase.

1 Like

Oh, started working now. :clap:

1 Like