Update package which contains bug

Hi,

I’m running on Expo SDK version 37, on IOS environment.
If I understood correctly I cannot update a specific package that I’m using for example
react-navigation-stack because I didn’t see an expo update API.
If I know there is a bug like the following one:

which I’ll need to update my dependency to a newer version in order to solve it, what do I need to do?

Thank you.

I think you should be able to upgrade react navigation. Give it a try. If it doesn’t work, what version are you using now and what version are you trying to upgrade to?

@wodin If I’m simply trying to do run: “expo install react-navigation-stack” it still leaves me with the same version react-navigation-stack@1.10.3, I’ll need to upgrade to at least 2.3.10.

Thank you very much from advance for your help,

If I expo init a new project and then follow the React Navigation v5 documentation:

$ expo install react-native-gesture-handler react-native-reanimated react-native-screens react-native-safe-area-context @react-native-community/masked-view
$ yarn add @react-navigation/stack

I end up with the following dependencies in my package.json:

  "dependencies": {
    "@react-native-community/masked-view": "0.1.6",
    "@react-navigation/stack": "^5.5.1",
    "expo": "~37.0.3",
    "react": "~16.9.0",
    "react-dom": "~16.9.0",
    "react-native": "https://github.com/expo/react-native/archive/sdk-37.0.1.tar.gz",
    "react-native-gesture-handler": "~1.6.0",
    "react-native-reanimated": "~1.7.0",
    "react-native-safe-area-context": "0.7.3",
    "react-native-screens": "~2.2.0",
    "react-native-web": "~0.11.7"
  },

If I instead follow the React Navigation v4 documentation:

$ expo install react-navigation react-native-gesture-handler react-native-reanimated react-native-screens
$ yarn add react-navigation-stack @react-native-community/masked-view react-native-safe-area-context

I get the following dependencies:

  "dependencies": {
    "@react-native-community/masked-view": "^0.1.10",
    "expo": "~37.0.3",
    "react": "~16.9.0",
    "react-dom": "~16.9.0",
    "react-native": "https://github.com/expo/react-native/archive/sdk-37.0.1.tar.gz",
    "react-native-gesture-handler": "~1.6.0",
    "react-native-reanimated": "~1.7.0",
    "react-native-safe-area-context": "^3.0.3",
    "react-native-screens": "~2.2.0",
    "react-native-web": "~0.11.7",
    "react-navigation": "^4.3.9",
    "react-navigation-stack": "^2.7.0"
  },

And here’s my environment:

$ expo diagnostics

  Expo CLI 3.21.5 environment info:
    System:
      OS: macOS Mojave 10.14.5
      Shell: 5.0.17 - /usr/local/bin/bash
    Binaries:
      Node: 12.18.0 - /usr/local/opt/node@12/bin/node
      Yarn: 1.22.4 - /usr/local/bin/yarn
      npm: 6.14.4 - /usr/local/opt/node@12/bin/npm
      Watchman: 4.9.0 - /usr/local/bin/watchman
    IDEs:
      Android Studio: 3.5 AI-191.8026.42.35.6010548
      Xcode: 11.3.1/11C504 - /usr/bin/xcodebuild
    npmPackages:
      expo: ~37.0.3 => 37.0.12 
      react: ~16.9.0 => 16.9.0 
      react-dom: ~16.9.0 => 16.9.0 
      react-native: https://github.com/expo/react-native/archive/sdk-37.0.1.tar.gz => 0.61.4 
      react-native-web: ~0.11.7 => 0.11.7 
      react-navigation: ^4.3.9 => 4.3.9 

I followed the same guidelines from a new project and it seems to be working.
Maybe because my version in expo SDK 37.0.0 and not 37.0.3.
Can I safely upgrade to it?
If I’m running this command it says that this version does not exist but I can try to it anyway.

@wodin the above didn’t work for me,
Can I use the npm-check-updates package and update the specific library by myself? or that’s breaks the expo managed workflow?

No, the SDK version is 37.0.1. See the react-native line from my package.json above.

The version of the expo dependency I was using was 37.0.12 as also shown above, because that was the latest version matching the ~37.0.3 pattern from package.json at the time.