Updating package.json with safe version numbers (not SDK)

Hello all,

I like to keep my package.json updated, usually I use ncu to do that, but that tool does not allow me to see what package versions are safe for expo.

Is there a sister command to expo install that updates the package.json to the latest known safe versions of the dependencies of a project? Ideally something that allows to:

  • List what packages can be updated and to what versions
  • Allows inclusion/exclusion based on a filter
  • Allows for a one-command package update and local packages installation

If this does not exist, can someone point me in the direction of where to query such safe version lists? Maybe I can find some time to extend the ncu package for expo.