Updating Sdk expo 36 to 37 gives me this error

  1. SDK Version: from 36 to 37
  2. Android and iOS
  3. running expo start gives this error : The package at “node_modules\babel-plugin-dotenv\index.js” attempted to import the Node standard library module “fs”. It failed because the native React runtime does not include the Node standard library. Read more at Using libraries - Expo Documentation
    Failed building JavaScript bundle.

Thanks

Hey @free4kids, that library is rather outdated. I would strongly suggest using a more updated and actively maintained library to handle your env variables. I’d take a look at our docs page on this: Environment variables in Expo - Expo Documentation

Cheers,
Adam

Once you have determined if the library is compatible, use expo-cli to install the package:

expo install @react-navigation/native

Be sure to follow the project website or README for any additional configuration and usage instructions. You can get to the README quickly using this command.

npx npm-home @react-navigation/native