Updating to v. 20 error (react-native-gesture-handler)


#1

I followed the medium article updating from v.19 to v.20 expo, and got the following warning when running “yarn install”:

“expo > react-native-gesture-handler@1.0.0-alpha.31” has incorrect peer dependency “react-native@>= 0.50.0"

That seemed odd, since Expo v.20 uses RN v.47. I ignored the warning, and tried running my app and got the following red screen:

I then ran “yarn why react-native-gesture-handler”, and it replied: This module exists because “expo” depends on it. Wierd. Here’s my app.json and package.json files.


#2

hey, not an npm pro but i believe if you have "expo": "^20.0.0" in your deps it will install the latest version since it means you are willing to download any version above 20. To simplify the sdk migration process I would specify "expo": "20.0.0" (dropped the ^)