"upgrade" is not an expo command. See "expo --help" for the full list of commands.

I am trying to upgrade expo sdk version from 37 to 38 and i am unable to do it. expo upgrade gives this error.

make sure you have the latest version of expo-cli

I have tried to install latest version and multiple times i tried npm install -g expo-cli. but i am still unable to get the upgrade command.

Can you run expo diagnostics and paste what’s printed out here?