upgrade to 27.0.0 problem of Chinese Input

#1

1.Chinese Input cannot Choose Chinese Charactor but only show English Charactors.(please help to solve this problem, thank you)

  1. always a warning of:
    Failed child context type: Invalid child context virtualizedCell.cellKey of type number supplied to CellRenderer, expected string.
  • node_modules/fbjs/lib/warning.js:33:20 in printWarning
  • node_modules/fbjs/lib/warning.js:57:25 in warning
  • node_modules/prop-types/checkPropTypes.js:52:18 in checkPropTypes
  • node_modules/react-native/Libraries/Renderer/ReactNativeRenderer-dev.js:11916:8 in processChildContext
  • node_modules/react-native/Libraries/Renderer/ReactNativeRenderer-dev.js:11970:46 in invalidateContextProvider
  • node_modules/react-native/Libraries/Renderer/ReactNativeRenderer-dev.js:8852:32 in finishClassComponent
  • node_modules/react-native/Libraries/Renderer/ReactNativeRenderer-dev.js:12924:25 in performUnitOfWork
  • node_modules/react-native/Libraries/Renderer/ReactNativeRenderer-dev.js:12953:43 in workLoop
  • node_modules/react-native/Libraries/Renderer/ReactNativeRenderer-dev.js:12996:17 in renderRoot
  • node_modules/react-native/Libraries/Renderer/ReactNativeRenderer-dev.js:13632:34 in performWorkOnRoot
  • node_modules/react-native/Libraries/Renderer/ReactNativeRenderer-dev.js:13545:26 in performWork
  • node_modules/react-native/Libraries/Renderer/ReactNativeRenderer-dev.js:13506:16 in performSyncWork
  • node_modules/react-native/Libraries/Renderer/ReactNativeRenderer-dev.js:13392:6 in requestWork
  • node_modules/react-native/Libraries/Renderer/ReactNativeRenderer-dev.js:13259:24 in scheduleWorkImpl
  • node_modules/react-native/Libraries/Renderer/ReactNativeRenderer-dev.js:6224:19 in enqueueSetState
  • node_modules/react/cjs/react.development.js:242:31 in setState
  • node_modules/react-redux/lib/components/connectAdvanced.js:222:24 in onStateChange
  • node_modules/redux/lib/createStore.js:186:6 in dispatch
  • actions/AuthActions.js:207:17 in
  • node_modules/@firebase/util/dist/cjs/src/subscribe.js:48:26 in
  • node_modules/@firebase/util/dist/cjs/src/subscribe.js:152:23 in
  • … 10 more stack frames from framework internals
#2

Hey @markmoo,

It appears this is an issue with react-native rather than Expo itself. https://github.com/facebook/react-native/issues/19104

If this is a blocker, I would suggest reverting back to SDK26 (or whichever version you know worked).

Cheers,

Adam

#3

I have been looking at this. 19104 seems to be the same as https://github.com/facebook/react-native/pull/18456 and if so, SDK26 also has this issue. I have not done that yet but I believe you will have patch in your own changes to the SDK packaged react-native in order to fix this temporary until the fix is merged into to react-native.

#4

thank you, my buddy

#5

I tried to patch my react native SDK according to this but it didn’t work when I tested my app on simulator and on device.

When I do the patch in react native without expo, it works fine. Please help.

#7

I downgraded to 25.0.0 waiting new RN version and expo to solve this problem

1 Like
closed #9

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.