Upgrade to SDK 26 from SDK 25

#1


Followed the upgrade instructions to a tee, also tried a fresh install with the latest expo cli and expo ide and create-react native app.

Just need some tips to debug these errors, I’m guessing the touchstart might be to do with a custom scrollview library. Not sure about the undefined module, but on the medium post for upgrade instructions I saw at least two other incidents of the same error.

#2

Hey @gregbenner, is your app detached?

#3

Nope!
more characters so i can post.

#4

Does anybody have an idea how to debug Unsupported top level event type topTouchStart dispatched

Is it possible to replace the push message service with 3rd party one?
#5

I’ve seen that error when importing some haste module, but I couldn’t tell you which :thinking:
You might try creating a new project with the same package.json to at least tell if it’s coming from one of your dependencies or you own code.

#6

Thanks, trying to add all the modules and test which is breaking one by one, but it’s super tedious. I saw later on haste-maps having an error but its unclear if that’s actually the root cause or just a chain reaction

#7

This is just stickler stuff, but in updating some of my apps (expo not CRNA) the most important thing I’ve found is making sure your .babelrc is correct.

{
  "presets": ["babel-preset-expo"],
  "env": {
    "development": {
      "plugins": ["transform-react-jsx-source"]
    }
  }
}

And you add these to your devDependencies in package.json

 "babel-preset-es2015": "^6.24.1",
 "babel-preset-stage-2": "^6.24.1",
1 Like
#8

I’ve got decorators also for Mobx that doesn’t matter too much hey?

  "presets": ["babel-preset-expo"],
  "env": {
    "development": {
      "plugins": [ "transform-decorators-legacy", "transform-react-jsx-source"]        
    }
  },
  "plugins": [[
    "module-resolver",
    {
      "root": ["./src"]
    }
  ]]
}```

I'll try updating the presets as per your suggestion right now it's

“babel-plugin-transform-decorators-legacy”: “^1.3.4”,
“babel-preset-es2015”: “^6.24.1”,
“babel-preset-react-native-stage-0”: “^1.0.1”,

#9

Well after 10 days full time trying to debug this looks like they broke React Navigation. https://github.com/react-navigation/react-navigation/issues/3416
If you are using Mobx (everyone should) Looks like someone is working on a solution https://github.com/Javascript-Ninja/react-navigation-mobx-helpers

1 Like
closed #10

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.