Using Expo Client with IOS 9.3.5

#1

Hello, i’m trying to use a original iPad Mini with IOS firmware 9.3.5 but when i try to open my app with the Expo Client app, it asks me to download the lastest version of the app for IOS 10.0.0. Is support for IOS 9 completely dropped or could i use an older version of Expo for developing?

1 Like
#2

Did you figure something out? I am having the same problem. I think a device bought 5 years ago should not be considered “legacy” given the price of Apple products.

#3

ios 9 is dropped indeed. are you unable to update the operating system on your device? version stats show that ios 9.x is at 5.7% usage so many apps are beginning to drop support for it: https://david-smith.org/iosversionstats/

#4

see the release notes that mention this: https://blog.expo.io/expo-sdk-v31-0-0-is-now-available-cad6d0463f49

#5

5.7% is like 1 in 20 people. In my opinion, that’s still a big number. Regardless, countries like India probably still use a lot of used or old versions of iOS devices because they are cheaper, like I do. Even if it is just 10% in India, that’s 1 in 10 people’s device that’s termed useless.

Another important point is that Expo is a development tool and not just another app that have all the freedom or market to decide for themselves. Any development tool should have as wide a spectrum as possible.

That said, I don’t contribute to Expo for the lack of coding skills, so I can’t be all demanding here.

#6

And yes, I am unable to update from the iOS version 9. It’s not allowed if you are using an old device (TBH my ipod is not that old, it works great and I use many other apps).

closed #7

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.